Print Page | Close Window

Crash, not connecting to database?

Printed From: ORCL Toolbox
Category: ORCL Toolbox
Forum Name: FormsTool
Forum Description: All questions/matters regarding FormsTool ...
URL: http://www.orcl-toolbox.com/forums/forum_posts.asp?TID=958
Printed Date: 14-August-2022 at 2:33pm
Software Version: Web Wiz Forums 11.01 - http://www.webwizforums.com


Topic: Crash, not connecting to database?
Posted By: formstooluser11
Subject: Crash, not connecting to database?
Date Posted: 04-August-2016 at 3:13pm
Hello, I have been using FormsTool for a few years now but am seeing problems with certain RDFs. I upgraded to the latest version trial v3.0 343 to see if it would help. It does give nicer fields for the database info and a very slightly better error, but still does not work properly.
  • When I try to use Property Explorer to open an RDF it fails with an error saying "Reports Converter has stopped working." Then the UI shows a little toast at the bottom saying "Error loading the module. Error: REP-0003:Error loading reports module! REX conversion failed."

  • It's the "REX" conversion message that is new with this latest version.
When I open Reports Converter manually and try a REX conversion it also fails.

BUT if I open Reports Converter and connect to the database first, it works.

So I went back to FormsTool and entered the database information. It still gives the exact same error. It does not even pause and say "Connecting to database" like it sometimes does on the Comparison tab.

It's as though it doesn't actually connect to the database.

I tried putting in a bad user name and it does not change the error message.

If I go to the comparison tab and enter two RDFs and the database credentials it DOES pause and say connecting to the database. (If I put in bad credentials here it does throw an error failing to connect to the database.)

But it still crashes with the same Reports Converter Stopped Working error.

It seems like this error can be handled because I am able to convert these RDFs to REX using the Reports Converter tool when I connect to the database first. It's as though FormsTool really is not connecting to the database each time it runs rwconverter.

I'm hoping we can get this fixed soon so we can keep using it!

Thanks

Some more information:

I ran FormsTool from the command line with the LOG parameter. Here's what I get.

8/4/2016 5:15:00 PM Log started
8/4/2016 5:15:00 PM TDevCompareApplicationModule.create
8/4/2016 5:15:00 PM TDevCompareApplicationModule.RunFromCLI
8/4/2016 5:15:00 PM   => Template=
8/4/2016 5:15:00 PM   => FilenameOld={removed for forum}.rdf
8/4/2016 5:15:00 PM   => DirectoryOld=
8/4/2016 5:15:00 PM   => FilenameNew={removed for forum}.rdf
8/4/2016 5:15:00 PM   => FilenameBase=
8/4/2016 5:15:00 PM   => ShowUnchangedObjAndProps=N
8/4/2016 5:15:00 PM   => IgnoreWhitespace=Y
8/4/2016 5:15:00 PM   => IgnorePropertyInheritance=N
8/4/2016 5:15:00 PM   => IgnoreComments=N
8/4/2016 5:15:00 PM   => CaseInsensitive=Y
8/4/2016 5:15:00 PM   => DBConnection=apps/{removed for forum}@{removed for forum}
8/4/2016 5:15:00 PM   => FILTER=ALL
8/4/2016 5:15:00 PM   => OUT=
8/4/2016 5:15:00 PM TFrameDevCompare.create
8/4/2016 5:15:19 PM TFrameDevCompareParamFile.create
8/4/2016 5:15:19 PM TFrameDevCompare.destroy
8/4/2016 5:15:23 PM TFrameDevCompareParamFile.destroy
8/4/2016 5:15:23 PM TDevCompareApplicationModule released
8/4/2016 5:15:23 PM TDevCompareApplicationModule.destroy

Here is what I see in the Windows Event Log:

Faulting application name: rwconverter.exe, version: 10.1.2.0, time stamp: 0x42ea43c6
Faulting module name: KERNELBASE.dll, version: 6.1.7601.23418, time stamp: 0x5708a7e4
Exception code: 0xebad198c
Fault offset: 0x0000c54f
Faulting process id: 0x1998
Faulting application start time: 0x01d1ee9ccf90b551
Faulting application path: c:\app\devsuitehome_1\bin\rwconverter.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 0e367ce1-5a90-11e6-a7a7-005056891c69



Replies:
Posted By: administrator
Date Posted: 06-August-2016 at 1:25am
You are correct, I am not connecting to the database when using the reports converter. 
I will fix that for the next version. please contact me on support@orcl-toolbox.com if you want a pre-release now to get around this issue.

Regards,
Stefan



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.01 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk